Windows8.1でrubyinstaller2を試してみる

以下のような説明があったので、試してみる。

http://qiita.com/KTakata/items/1f30b8571764f7801708
RubyInstaller2
でRuby2.4 with Rails5の環境を作る~Nokogiriでエラー~
KTakata
2017年03月09日に更新

(環境)
Windows8.1
rubyinstaller2.4.0-8
Rails 5.0.2

(1)以下のページから、

rubyinstaller-2.4.0-8-x64.exe

をダウンロードしてインストール。

https://github.com/larskanis/rubyinstaller2/releases

image

image

image

image

image

image

3 を入力して、Enter

image

image

msys2-x86_64-ほにゃららのダウンロードに、けっこう時間がかかる。

image

image

image

image

image

image

image

image

image

ものすごく時間がかかる。。。

image

image

ここからがよくわからない

cmd.exe

image

image

image

image

image

image

image

image

ここでもかなり待つ

image

c:/ に、 work フォルダを作成し、

image

お、なんだか、Windowsで普通にRailsがインストールできそう。

image

image

rails new sample
cd sample
rails s

image

エラーでうまくいかず

(2)以下のページを見ながら、、、

http://qiita.com/jnchito/items/08b5be458134073c60e3#nokogiri%E3%81%AE%E3%82%A8%E3%83%A9%E3%83%BC%E3%81%AB%E5%AF%BE%E5%BF%9C%E3%81%99%E3%82%8B
RubyInstaller2でWindows環境にRuby 2.4 + Rails 5.0.2をインストールする
jnchito
2017年03月07日に更新

image

image

ややこしいが、上記の通りにやってみる。Versionの番号だけ、少し異なるかも。

image

image

image

image

間違えた

image

おお!うまくいったか?

image

やった!うまくいった。

image

これで、Windows上で、Railsがやっと動かせるようになった。。。
gemのインストールは、やや難しいのかもしれないが、、、

(2)

関連記事
Count per Day
    Popular Posts
    スポンサーリンク

    シェアする

    • このエントリーをはてなブックマークに追加

    フォローする